Heartbleed Bug

Picatinny Federal Credit Union (PFCU) is aware of the Heartbleed bug, a vulnerability that is potentially affecting many websites and systems globally. PFCU is not affected by the Heartbleed OpenSSL threat.

Web services employed for member use by PFCU do not utilize the OpenSSL software and therefore are not open to this vulnerability. Additionally, PFCU uses technology to prevent unauthorized access to our networks and to sensitive member information. As a best practice, PFCU recommends changing your passwords periodically.